Intermittent Payment Delays/Timeouts
Incident Report for MX Merchant
Resolved
We are confident this issue has been resolved. We will continue to monitor for any further timeouts and update as needed.
Posted over 2 years ago. Oct 11, 2016 - 18:50 EDT
Investigating
We are investigating reports of intermittent payment timeouts. We believe this issue is impacting a small number of payments using specific token types and will provide updates as available.
Posted over 2 years ago. Oct 11, 2016 - 18:27 EDT