First Data Omaha outage - initial recovery failed
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted about 3 years ago. Dec 04, 2015 - 21:53 EST
Identified
First Data has reported the initial resolution failed. Various Omaha platforms are degraded again.
Posted about 3 years ago. Dec 04, 2015 - 12:23 EST