MX Merchant Two Factor Notifications Delays
Incident Report for MX Merchant
Resolved
The two factor issues we were experiencing with MX Merchant (https://mxmerchant.com/) appear to be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Feb 26, 2021 - 10:54 EST
Investigating
We are investigating reports of delays with two-factor notifications with MX Merchant (https://mxmerchant.com/). We are actively researching and will provide more information shortly.
Posted Feb 26, 2021 - 09:21 EST
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).