MX Merchant Payment Failures
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted Jan 27, 2023 - 14:37 EST
Identified
The cause of this outage has been identified. Our team is continuing to work on a resolution. We will provide another update shortly.
Posted Jan 27, 2023 - 14:09 EST
Investigating
We are investigating reports of payment failures. We are actively researching and will provide more information shortly.
Posted Jan 27, 2023 - 13:32 EST
This incident affected: MX Merchant and Checkout API.