INVESTIGATING: Unable to switch Merchants
Incident Report for MX Merchant
Resolved
The issue has been fixed. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Nov 02, 2023 - 13:38 EDT
Update
We have implemented a fix for the main issue, and are looking into other minor fixes that may be needed.
Posted Nov 02, 2023 - 12:50 EDT
Monitoring
We have implemented a fix for the main issue, and are looking into other minor fixes that may be needed.
Posted Nov 02, 2023 - 11:36 EDT
Update
We are continuing to investigate a minor issue that is affecting a select few merchants.
Posted Nov 02, 2023 - 10:34 EDT
Investigating
We are investigating a minor issue that is affecting a select few merchants.
Posted Nov 02, 2023 - 09:38 EDT
This incident affected: MX Merchant.