Site maintenance
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted over 3 years ago. Aug 04, 2015 - 17:27 EDT
Update
All Clear - [test message, please ignore]
Posted about 4 years ago. Feb 24, 2015 - 17:14 EST
Investigating
[Test Message] - Our data center has informed us that they will be performing routine network maintenance. No interruption in service is expected. Any issues during this maintenance should be directed to our Help Desk
Posted about 4 years ago. Feb 24, 2015 - 13:25 EST