Service disruption - MX Merchant latency
Incident Report for MX Merchant
Resolved
Issue has been resolved.
Posted over 2 years ago. May 09, 2017 - 16:14 EDT
Monitoring
Services have been restored but are still being monitored for further issues.
Posted over 2 years ago. May 09, 2017 - 13:47 EDT
Investigating
We're investigating reports of latency with MX Merchant. We will provide more information shortly.
Posted over 2 years ago. May 09, 2017 - 13:21 EDT