MX Merchant payment failures
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 18:14 EST
Update
We are continuing to monitor for any further issues.
Posted Jan 13, 2025 - 15:57 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2025 - 15:56 EST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2025 - 14:29 EST
Investigating
We are investigating reports of payment failures. We are actively researching and will provide more information shortly.
Posted Jan 13, 2025 - 13:55 EST
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).