Service disruption - MXM latency
Incident Report for MX Merchant
Resolved
Services have been restored.
Posted about 2 years ago. May 16, 2017 - 14:06 EDT
Monitoring
Services have been restored but are still being monitored for further issues.
Posted about 2 years ago. May 16, 2017 - 14:04 EDT
Investigating
We are currently investigating the cause of the service disruption.
Posted about 2 years ago. May 16, 2017 - 13:24 EDT