Sluggish Performance
Incident Report for MX Merchant
Resolved
We have recovered from high utilization conditions for the past hour and we are declaring this incident as clear. Analysis continues on the root cause and conditions are being monitored closely.
Posted over 2 years ago. Feb 01, 2017 - 15:33 EST
Investigating
We are currently experiencing high utilization on this platform resulting in sluggish performance. We are investigating and will update as conditions change.
Posted over 2 years ago. Feb 01, 2017 - 12:18 EST