MX Merchant SMS Notification Latency
Incident Report for MX Merchant
Resolved
This issue has been resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Nov 06, 2023 - 18:55 EST
Monitoring
We have implemented a fix for the latency with receiving SMS Notifications from or otherwise related to MX Merchant (https://mxmerchant.com/). We will continue to monitor and ensure all operations are functional.
Posted Nov 06, 2023 - 17:05 EST
Investigating
We are investigating reports of latency with receiving SMS Notifications from or otherwise related to MX Merchant (https://mxmerchant.com/). We are actively researching and will provide more information shortly.
Posted Nov 06, 2023 - 12:54 EST
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).