MX Merchant latency
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 16:26 EDT
Investigating
We are investigating reports of latency with MX Merchant (https://mxmerchant.com/). We are actively researching and will provide more information shortly.
Posted Mar 15, 2023 - 15:40 EDT
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).