First Data Omaha outage
Incident Report for MX Merchant
Resolved
First Data has confirmed full restoration of services. We will continue to monitor traffic and advise of any change in condition.
Posted over 3 years ago. Dec 04, 2015 - 12:06 EST
Update
FD is reporting full restoration of services. Services will continue to be monitored.
Posted over 3 years ago. Dec 04, 2015 - 11:32 EST
Monitoring
We are now observing successful transactions passing on First Data Omaha. This will continue to be monitored.
Posted over 3 years ago. Dec 04, 2015 - 10:30 EST
Update
Limited services are recovered.
Posted over 3 years ago. Dec 04, 2015 - 10:20 EST
Update
No update at this time.
Posted over 3 years ago. Dec 04, 2015 - 10:15 EST
Identified
First Data Omaha has confirmed an outage of their payment platforms. The incident is being worked and updates will be provided as available.
Posted over 3 years ago. Dec 04, 2015 - 09:47 EST