MX Merchant is experiencing intermittent outage

Incident Report for MX Merchant

Resolved

The availability issues we were experiencing with MX Merchant (https://mxmerchant.com/) appears to be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Dec 15, 2024 - 12:31 EST

Investigating

We are investigating that MX Merchant (https://mxmerchant.com/) is experiencing an intermittent outage . The team is actively investigating and will implement a fix as soon as possible.
Posted Dec 15, 2024 - 11:45 EST
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).