SMS Delivery Delays
Incident Report for MX Merchant
Resolved
The SMS delays we were experiencing with MX Merchant (https://mxmerchant.com/) have been resolved. We apologize for any inconvenience and thank you for your patience and continued support.
Posted May 25, 2023 - 10:10 EDT
Monitoring
A fix has been implemented by our SMS service provider and we are continuing to monitor the results for any other issues related to SMS deliveries. Thank you for your patience
Posted May 25, 2023 - 06:22 EDT
Update
We are still experiencing SMS delivery delays when sending messages to some U.S. cellular networks. We are engaged with our SMS service partner to resolve the issue. We will provide another update as more information becomes available
Posted May 25, 2023 - 02:25 EDT
Update
We continue to experience SMS delivery delays when sending messages to some U.S. cellular networks. We are engaged with our SMS service partner to resolve the issue. We will provide another update as more information becomes available.
Posted May 25, 2023 - 00:12 EDT
Identified
We are experiencing SMS delivery delays when sending messages to some U.S. cellular networks. We are engaged with our SMS service partner to resolve the issue. We will provide another update as more information becomes available.
Posted May 24, 2023 - 20:15 EDT
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).