MX Merchant latency

Incident Report for MX Merchant

Update

We are continuing to monitor for any further issues.
Posted Dec 05, 2025 - 17:49 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 15:41 EST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 14:16 EST

Investigating

We are investigating reports of latency with MX Merchant (https://mxmerchant.com/). We are actively researching and will provide more information shortly.
Posted Dec 05, 2025 - 13:08 EST
This incident affects: MX Merchant and Checkout API.