MxMerchant is Currently Down. Unable to Sign in.
Incident Report for MX Merchant
Resolved
The availability issues we were experiencing with MX Merchant (https://mxmerchant.com/) appears to be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted Sep 28, 2023 - 19:08 EDT
Monitoring
MxMerchant is now operational and we will continue to monitor the site performance.
Posted Sep 28, 2023 - 18:04 EDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2023 - 17:41 EDT
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).