MXM Maintenance Notice
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted Sep 18, 2024 - 04:48 EDT
Identified
We are currently performing scheduled maintenance on MXM to enhance its performance and reliability. During this period, you may experience intermittent access or reduced functionality. We apologize for any inconvenience this may cause and appreciate your patience as we work to improve your experience
Posted Sep 18, 2024 - 04:16 EDT
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).