NICE inContact not connecting with Agents
Incident Report for MX Merchant
Resolved
Teams are getting calls now successful. Issue resolved
Posted Jan 24, 2025 - 16:50 EST
Update
Our engineers and support teams have identified the problem and are currently
repairing the technical issue. Please stay tuned for further updates.
Posted Jan 24, 2025 - 16:32 EST
Update
Our engineers and support teams have identified the problem and are currently
repairing the technical issue. Please stay tuned for further updates.
Posted Jan 24, 2025 - 15:53 EST
Update
Our engineers and support teams have identified the problem and are currently
repairing the technical issue. Please stay tuned for further updates.
Posted Jan 24, 2025 - 15:17 EST
Identified
Service is now recovered and we are monitoring. If you are still experiencing issues please contact support.
Identified - Our engineers and support teams have identified the problem and are currently
repairing the technical issue. Please stay tuned for further updates.
Posted Jan 24, 2025 - 14:44 EST
Update
We are continuing investigating the issue
Posted Jan 24, 2025 - 14:42 EST
Update
We are currently experiencing an issue with our phone system. We are working with our phone provider to resolve this situation. We apologize for the incovience
Posted Jan 24, 2025 - 11:49 EST
Investigating
We are currently investigating the issue
Posted Jan 24, 2025 - 11:37 EST
This incident affected: MX Merchant.