MXM is Experiencing sign-in Issues/Latency
Incident Report for MX Merchant
Resolved
MXMerchant Authentication has been restored. We will continue to monitor to confirm this is resolved.
Posted Apr 03, 2023 - 10:11 EDT
Investigating
We are currently investigating this issue.
Posted Apr 03, 2023 - 09:47 EDT
This incident affected: MX Merchant.