MX Merchant latency

Incident Report for MX Merchant

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 20:01 EST

Update

We are continuing to investigate this issue.
Posted Feb 04, 2025 - 18:00 EST

Investigating

We are investigating reports of latency with MX Merchant (https://mxmerchant.com/). We are actively researching and will provide more information shortly.
Posted Feb 04, 2025 - 14:52 EST
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).