MasterCard Declined Authorizations
Incident Report for MX Merchant
Resolved
The problem with MasterCard Authorizations appears to be resolved. We apologize for the inconvenience and thank you for your patience and continued support. Please rest assured that system reliability is a top priority at Priority Payment Systems, and we are making continuous improvements to make our systems better.
Posted almost 3 years ago. Jun 14, 2016 - 11:04 EDT
Monitoring
A hotfix has been promoted to the production environment to address the MasterCard card type issue previously reported.

The situation will continue to be closely monitored.

Thank you for your patience while we address the issue.
Posted almost 3 years ago. Jun 14, 2016 - 10:22 EDT
Investigating
We are investigating reports of an increased volume of declined MasterCard authorizations. We will provide more information shortly
Posted almost 3 years ago. Jun 14, 2016 - 09:45 EDT