MX Merchant Issues
Incident Report for MX Merchant
Resolved
This incident has been resolved.
Posted Oct 20, 2023 - 15:00 EDT
Update
We have implemented a fix and are monitoring to ensure that all operations are functional.
Posted Oct 20, 2023 - 10:26 EDT
Investigating
We are aware of new reports that some features on MX Merchant (https://mxmerchant.com/) are unavailable and/or delayed. We are actively researching and will provide more information shortly.
Posted Oct 20, 2023 - 08:32 EDT
This incident affected: MX Merchant, Checkout API, MX Merchant Retail (iOS App), and MX Merchant Express (iOS App).