MX Merchant payment failures
Incident Report for MX Merchant
Resolved
This issue has been resolved.
Posted Oct 01, 2019 - 11:03 EDT
Investigating
We are investigating reports of payment failures. We are actively researching and will provide more information shortly.
Posted Oct 01, 2019 - 10:58 EDT
This incident affected: Checkout API.